当前位置:首页 > 问答

通达信公式破解

我来帮TA回答

如何破解通达信公式的时间限制?

鼠标指定你要修改的指标,右击“当前指标”点击“修改指标参数”,就能看到源码。
时间限制是一种加密的方法,其原理是在指标中加入时间函数,把时间设定在一定的使用范围内,当超过设定的时间之后,指标图形中的线条和有关信号消失或失真,造成指标不能继续使用。用时间限制加密的形式有多种,举例子加以说明解除的方法:
看这个副图指标:
Var1:=IF(DATE<=1040701,1,0);
Var2:=DMA(CLOSE,HIGH/MA(LOW,4)/4);
Var3:=DMA(CLOSE,CLOSE/MA(LOW,30)/30);
Var4:=(LOW-Var2)/Var2*100<-5.889;
Var5:=(Var2-Var3)/Var3*100<-15.889;
Var6:=Var4 AND Var5 AND (HIGH-MA(LOW,3))/REF(LOW,2)>-0.059;
Var7:=Var6>0;
Var8:=AMOUNT/VOL/100;
Var9:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VarA:=SUM(AMOUNT,13)/Var8/100;
VarB:=DMA(Var9,VOL/VarA);
VarC:=MA(HHV(HIGH,488),18);
VarD:=MA(HHV(HIGH,220),18);
VarE:=MA(HHV(HIGH,98),18);
VarF:=MA(LLV(LOW,488),18);
Var10:=MA(LLV(LOW,220),18);
Var11:=MA(LLV(LOW,98),18);
Var12:=MA((VarF*0.96+Var10*0.96+Var11*0.96+VarC*0.558+VarD*0.558+VarE*0.558)/6,18);
Var13:=MA((VarF*1.25+Var10*1.23+Var11*1.2+VarC*0.55+VarD*0.55+VarE*0.65)/6,18);
Var14:=MA((VarF*1.3+Var10*1.3+Var11*1.3+VarC*0.68+VarD*0.68+VarE*0.68)/6,18);
Var15:=MA((Var12*3+Var13*2+Var14)/6*1.738,18);
Var16:=IF(DATE<=1021231,Var15,Var15*DAY);
Var17:=LOW;
Var18:=REF(LOW,1);
Var19:=SMA(ABS(Var17-Var18),3,1)/SMA(MAX(Var17-Var18,0),3,1)*100;
Var1A:=MA(IF(CLOSE*1.35{<=Var16},Var19*10,Var19/10),3);
Var1B:=LLV(LOW,30);
Var1C:=HHV(Var1A,30);
Var1D:=IF(LOW<=Var1B,(Var1A+Var1C*2)/2,0);
Var1E:=MA(Var1D AND CLOSE<COST(1),3) AND (CLOSE-VarB)/VarB*100<-11;
Var1F:=MA(CLOSE,5);
Var20:=MA(CLOSE,10);
Var21:=MA(CLOSE,20);
Var22:=MA(CLOSE,30);
Var23:=(Var1F+Var20+Var21+Var22)/4;
Var24:=(Var23-REF(Var23,15))/REF(Var23,15)*100;
Var25:=IF(Var24<-10 AND Var24<REF(Var24,1),20,0);
买入: Var7*Var1 AND Var1E*Var1 AND Var25*Var1 AND (CLOSE-OPEN)*Var1>0,linethick2 , colorred;
这个指标中的VAR1、VAR16和买入这3条语句引用了时间限制函数,限制在2004年7月1日前可正常使用,超过这个时间就不能正常使用了。解除时间限制的方法比较简单,只要把VAR1和VAR16这2条语句删除,再把买入语句中的*VA1删除就完全解除了时间限制。
最后再看一个指标:
Var1:=IF(DATE<1030830 AND DATE>900101,1,0);
Var2:=LLV(LOW,10);
Var3:=HHV(HIGH,25);
警戒线:=2.8*Var1;
减仓线:=3.2*Var1;
动力线:=EMA((CLOSE-Var2)/(Var3-Var2)*4,4)*Var1;
VAR4:CROSS(动力线,警戒线);
STICKLINE(VAR4,0,50,4,0);
DRAWICON(CROSS(动力线,警戒线),53,2);
这个指标中的VAR1引用了时间限制函数,限制在2003年8月30日前可正常使用,超过这个时间就不能正常使用了。解除时间限制的方法比较简单,只要把VAR1这条语句删除,再把语句中的*VAR1删除就完全解除了时间限制。
以上例举了2个解除时间限制的方法,试一下吧!

通达信完全加密公式能破解吗

通达信的完全加密公式
对此个人观点是此类公式不可解,其原因是解开以后是乱码的情况常见。
如果是普通的加密,可以用网上常见的和谐一下,基本都可以解决。
对于完全加密的公式,还是建议不要多想了。

内容通达信公式显示2020年4月20日到期,请问如何破解?

这段代码的有效期可以取消,修改公式就可以。但你这公式代码的有效期跟你截图的有效期也不是同一时间啊。

通达信加密公式怎么破解?有导入密码的呢?导出密码或者是使用时间限制的呢?

有专门的软件吧,记得优酷上有视频,搜索下吧。密码的破解是通达信公式破解器,淘宝通股博金店36.8吧。导入密码的貌似也有工具,但没有见过出售的。

通达信的加密公式如何破解

我新公布的方法在理想论坛的证券软件交流区:http://www.55188.com/thread-4452396-1-1.html
若不会技术,那里还有tcalc.dll的替换软件,直接替换即可。。

通达信公式指标的导入密码如何破解?

通达信公式破解方法 公式破解方法 1:不是使用Winhex,而是使用Ollydbg来破解. 2:只是用户公式修改密码有效。对于导入密码无效。对于系统公式密码无效,默认的系统公式密码可能是OK_TDX(测试了两个版本,其他的不知道) 不过好像有的不能编辑,不过VOL_TDX等系统的公式好像可以查看和修改。 方法: 1:使用Ollydbg,点文件,打开,选择通达信的可执行文件(或者把通达信的执行文件直接拖进Ollydbg的窗口),按F9运行程序。 2:正常使用通达信,进入到K线图后,在k线图(主图或者副图上)点右键,选择指标,然后选择一个加密的公式,点确定。 此时公式应该能正确使用并且在图上显示出来。 3:点右键,选当前指标,选修改指标公式,此时需要输入密码,随便输入几个数,但不要点确定。 4:在Ollydbg的左下角,有一个命令编辑框,输入命令bp _mbscmp,回车,这时断点下好了。 5:点修改密码公式框中的确定按钮,此时中断在_mbscmp中,在右上角的EAX的值就是密码,ECX值是你随便输入的数。 6:找到密码后,点在左上角的红黑色的一行代码,点F2取消断点,再点F9来继续程序执行。可以循环2-6步来得到其他的密码。 7:完成,哈哈。 各位可以去试一试,^_^。方法原创,只是交流,无其他目的,谢谢。 对系统公式无效,是指使用系统默认密码OK_TDX,能打开但是不能查看和编辑。 不过对于有的系统公式如VOL_TDX需要密码的,可以使用默认密码来查看它。